M365 and Outlook Issues reported by Microsoft
Incident Report for Mailprotector
Resolved
Microsoft continues to have an open incident regarding mail flow issues to M365 Exchange Online. Please see https://twitter.com/MSFT365Status/status/1391805371824607235 for more information.

Mailprotector believes this was the cause of delivery delays over the last couple of days. Exchange Online Protection & Defender for 365 were erroneously flagging messages as malicious and rate-limiting connections. The implementation or deletion and recreation of inbound connectors was a consistent workaround for most tenants affected by this incident.

Mailprotector will keep this service announcement monitored until Microsoft closes the incident.
Posted May 12, 2021 - 16:44 EDT
Monitoring
Microsoft has reported an incident regarding users not able to view emails in Outlook. Please see https://twitter.com/MSFT365Status/status/1392208966231355392 for more information.

We are also receiving continued reports of domains having trouble delivering email to M365 Exchange Online. Please ensure the domain has an inbound connector configured and enabled to accept messages from Mailprotector. The KB article for inbound connector configuration is https://support.mailprotector.com/hc/en-us/articles/115005484203-Office-365-Inbound-Connector
Posted May 11, 2021 - 18:14 EDT
This incident affected: Service Announcements.