Management Console Latency
Incident Report for Mailprotector
Resolved
Console speeds have been normalized. We are continuing to monitor. Sorry for the delay.
Posted over 1 year ago. Jun 09, 2017 - 13:26 EDT
Investigating
Slow response and timeouts on the console.mailprotector.com website. Our operations team is investigating now.
Posted over 1 year ago. Jun 09, 2017 - 12:15 EDT