Corporate office Internet services down
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted 11 months ago. Oct 25, 2017 - 14:28 EDT
Identified
An area-wide ISP outage is affecting Internet access for Mailprotector's corporate headquarters. Please expect a delayed response from sales and support staff during this outage.
Posted 11 months ago. Oct 25, 2017 - 11:25 EDT