Outlook on the Web 2016 Not Responding
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted 18 days ago. Nov 28, 2018 - 18:44 EST
Monitoring
One of the Exchange servers became unresponsive. Users that attempted to connect to this server when accessing Outlook on the Web received a timeout error. The server has been fixed and this issue is resolved. We will continue to monitor the situation.
Posted 18 days ago. Nov 28, 2018 - 16:50 EST
Investigating
Some users are reporting inability to reach the Outlook on the Web 2016. We are investingating the issue.
Posted 18 days ago. Nov 28, 2018 - 16:46 EST
This incident affected: Exchange+ 2016.