Yahoo reporting temporary deferrals
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted 9 months ago. Jun 02, 2017 - 08:30 EDT
Monitoring
We are now seeing queued messages delivering successfully to Yahoo addresses. Current tests are delivering in real-time as well.

We are continuing to monitor the situation.
Posted 9 months ago. Jun 01, 2017 - 23:15 EDT
Investigating
Mailprotector is investigating and working with Yahoo in response to temporary deferred messages reported by Yahoo on their inbound mail systems. Anyone using Yahoo DNS may also see temporary delays. Mailprotector will continue to queue and attempt delivery until this issue is resolved.
Posted 9 months ago. Jun 01, 2017 - 13:43 EDT