SSL Certificate Renewal In Progress
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted Apr 30, 2021 - 16:24 EDT
Monitoring
The SSL certificates have been reapplied and appear to be verifying as expected.
Posted Apr 30, 2021 - 15:35 EDT
Identified
The SSL certificate renewal on the Exchange 2016 platform has not completed as expected. The team is working on the issue. Accessing the Exchange Management Panel is safe to use despite the current warning.
Posted Apr 30, 2021 - 15:33 EDT