Exchange+ Degraded Performance
Incident Report for Mailprotector
Resolved
Exchange+ systems continue to show 100% operability with no reported delays.

There will me no further updates regarding this issue on the status page. If you have questions or any further issues, please contact us at support@mailprotector.com.
Posted Nov 18, 2015 - 18:06 EST
Monitoring
At this time, all Mailprotector Exchange+ users should be able to access their mailboxes. Access via Outlook or OWA may be slow, however, as we work to re-optimize our systems. Mailprotector Support and Engineering staff will continue to monitor the Exchange+ platform, and we will continue to update you as this situation progresses.
Posted Nov 18, 2015 - 11:48 EST
Update
Mailprotector engineers are continuing to work on restoring service to users who are still affected by this morning's Exchange+ issue.

Unfortunately, we cannot offer an ETA for resolution at this time, however we will continue to keep you updated via the status page: (http://status.mailprotector.com/).

Please accept our apologies for this ongoing issue, and do feel free to reach out to us with any questions or concerns at support@mailprotector.com or 1 800 393 4840
Posted Nov 18, 2015 - 11:42 EST
Update
Mailprotector engineers are continuing to work on restoring service to users who are still affected by this morning's Exchange+ issue.

Unfortunately, we cannot offer an ETA for resolution at this time.

Further updates will be provided via the Mailprotector status page (http://status.mailprotector.com/).

Please accept our apologies for this ongoing issue, and do feel free to reach out to us with any questions or concerns at support@mailprotector.com or 1 800 393 4840
Posted Nov 18, 2015 - 10:49 EST
Update
Mailprotector engineers are continuing to work on restoring service to users who are still affected by this morning's Exchange+ issue. Although we cannot offer an ETA for resolution at this time, we will keep you updated via the status page (http://status.mailprotector.com/). Please do feel free to reach out to us with any questions or concerns at support@mailprotector.com or 1 800 393 4840
Posted Nov 18, 2015 - 09:46 EST
Update
Mailprotector engineers are still working to restore service to a small number of still-affected users. Although we cannot offer an ETA for resolution at this time, we will keep you updated via the status page (http://status.mailprotector.com/). Please do feel free to reach out to us with any questions or concerns at support@mailprotector.com or 1 800 393 4840
Posted Nov 18, 2015 - 08:47 EST
Update
At this time, Mailprotector engineers are continuing to restore service to affected users. Currently, a small number of users are still affected; service to these users will be restored shortly.

Next update will be posted within 30 minutes.
Posted Nov 18, 2015 - 08:00 EST
Identified
Mailprotector engineers have identified the issue with the Exchange+ platform, and are working to restore service as quickly as possible to affected users. At this time, no messages have been lost, however, some users may still be unable to connect to their mailboxes. Additional updates will be forthcoming.
Posted Nov 18, 2015 - 06:58 EST
Investigating
Mailprotector Engineers are currently investigating an issue with the Exchange+ service which has left some users unable to connect to their mailboxes via Outlook. Additional updates will be forthcoming.
Posted Nov 18, 2015 - 06:55 EST