Exchange+ 2016 Delivery Delays for Some Users
Incident Report for Mailprotector
Resolved
The incident is resolved. Given the intermittent nature of this reported problem, we will continue monitoring for problems and new reports.
Posted 11 months ago. Dec 10, 2018 - 18:13 EST
Monitoring
Email delays appear to have stopped and no new reports have been submitted. The team is continuing to investigate and gather information. The Exchange+ services are operational. Thank you.
Posted 11 months ago. Dec 10, 2018 - 16:21 EST
Update
The email delivery delays have been intermittent and do not appear happening at the moment. We are continuing to monitor and investigate the reported issue.
Posted 11 months ago. Dec 10, 2018 - 15:29 EST
Investigating
A small percentage of users are reporting delivery delays. The team is investigating.
Posted 11 months ago. Dec 10, 2018 - 13:45 EST
This incident affected: Exchange+ 2016.