0-day exploit targeting Exchange Servers
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 16:41 EST
Monitoring
Partners managing on-premise Exchange Servers - please see Microsoft's security notice about HAFNIUM. https://tinyurl.com/nabayxsk
Posted Mar 03, 2021 - 11:18 EST
This incident affected: Service Announcements.