Degraded performance - Mailprotector CloudFilter
Incident Report for Mailprotector
Resolved
We have identified and resolved the issue with inbound delays. All inbound email is delivering within our normal transport threshold. Let us know if you experience any problems.
Posted almost 2 years ago. Feb 22, 2017 - 17:49 EST
Investigating
We are investigating issues related to delays and errors reported with inbound email.
Posted almost 2 years ago. Feb 22, 2017 - 16:40 EST