Exchange certificate error
Incident Report for Mailprotector
Resolved
The certificate error with Exchange+ 2013 has been resolved.
Posted over 1 year ago. May 03, 2017 - 15:55 EDT
Investigating
We are investigating a certificate error message with Exchange+ 2013. This is specific to the exchange.mailprotector.com hostname. This does not affect Exchange+ 2016.
Posted over 1 year ago. May 03, 2017 - 15:42 EDT