Inbound email delivery delay
Incident Report for Mailprotector
Resolved
Inbound email delays have returned to normal again. Increases in resources have been staged, and we will monitor the system in the morning.
Posted Aug 03, 2022 - 18:22 EDT
Identified
The team has observed the inbound email delay creep back up. We are working on the issue.
Posted Aug 03, 2022 - 16:36 EDT
This incident affected: CloudFilter and SafeSend Email Security.