Exchange+ Panel and OWA unreachable
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 17:13 EST
Monitoring
The server running the Exchange+ Panel was not responsive. The team has restarted the server, and we will continue to monitor the services.
Posted Feb 11, 2020 - 15:24 EST
Investigating
The Exchange+ Panel and access to OWA are not reachable. We are investigating the issue.
Posted Feb 11, 2020 - 15:07 EST
This incident affected: Exchange+ 2016.