Outbound emails delayed
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted Jul 27, 2020 - 16:55 EDT
Monitoring
A compromised mailbox affected the outbound queue on one server, causing delays for mailboxes also on this server. The compromised mailbox has been addresses and the queue has been cleaned up. Normal mail flow is confirmed and we will continue to monitor the situation.
Posted Jul 27, 2020 - 14:31 EDT
Investigating
We have received reports of outbound email delays from the hosted Exchange+ 2016 platform. We are investigating the issue.
Posted Jul 27, 2020 - 14:00 EDT
This incident affected: Exchange+ 2016.