Delays in outbound
Incident Report for Mailprotector
Resolved
The outbound delay condition has been resolved and we have moved the current SafeSend/Outbound service to fully operational (green). We are continuing to monitor for any degradation. If you experience any further issues please let our support team know.
Posted about 1 year ago. Dec 13, 2016 - 16:19 EST
Identified
Some users are experiencing delays in outbound delivery. This delay was triggered by a coordinated attack. Mailprotector engineers have identified the source and taken action to mitigate and restore to optimal transport times. We are continuing to monitor and verify everything is 100%. We will update via the status channel in one hour.
Posted about 1 year ago. Dec 13, 2016 - 15:21 EST