SafeSend Rule Results Not Returned
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 27, 2018 - 13:11 EDT
Monitoring
SafeSend rules on outbound messages are routing emails correctly. We will continue to monitor the system.
Posted 6 months ago. Mar 27, 2018 - 10:08 EDT