Console Displayed Error
Incident Report for Mailprotector
Resolved
The Management Console is operating normally.
Posted 5 months ago. Feb 12, 2018 - 16:30 EST
Monitoring
The Management Console experienced a brief outage due to an error. The Console is operational and we are continuing to monitor the situation.
Posted 5 months ago. Feb 12, 2018 - 15:49 EST