Intermittent Phone Menu Problem
Incident Report for Mailprotector
Resolved
The phone system is operating as expected. Thank you.
Posted 5 months ago. Mar 02, 2018 - 18:42 EST
Update
The phone system call menu is accepting key presses from most phone calls. We have continued reports of key presses from mobile phones not being accepted. In those cases, please call (864) 335-1064 to reach the support team. Thank you.
Posted 5 months ago. Mar 02, 2018 - 10:12 EST
Identified
Mailprotector has identified a problem with the phone system menu, preventing some callers from successfully connecting to a department. If seeking the support team, please call (864) 335-1064.
Posted 5 months ago. Mar 01, 2018 - 17:25 EST