Email Delivery Delays
Incident Report for Mailprotector
Resolved
Email flow delays have been resolved. Thank you.
Posted 9 months ago. Mar 19, 2018 - 17:38 EDT
Identified
We continue to see minor delays in email flow of a couple of minutes. The team is working to resolve the problem. Thank you.
Posted 9 months ago. Mar 19, 2018 - 16:26 EDT
Monitoring
The email delays have been resolved. Thank you.
Posted 9 months ago. Mar 19, 2018 - 15:28 EDT
Identified
The issue has been identified. The DevOps team is working on the resolution.
Posted 9 months ago. Mar 19, 2018 - 15:25 EDT
Investigating
Email delays are being reported for both inbound and outbound messages through the perimeter. Delays of 10 to 20 minutes have been reported. We are investigating the issue.
Posted 9 months ago. Mar 19, 2018 - 15:20 EDT