Management Console Error
Incident Report for Mailprotector
Resolved
The Console has been restored to normal operation.
Posted 11 days ago. Feb 13, 2018 - 16:33 EST
Investigating
We are investigating a 504 error when accessing the Console.
Posted 11 days ago. Feb 13, 2018 - 16:27 EST