Mail flow delays
Incident Report for Mailprotector
Resolved
The DevOps team has confirmed that email delivery has returned to normal as of approximately 4:40 PM ET. No further delays are expected. Thank you.
Posted May 04, 2020 - 18:04 EDT
Monitoring
Around 4:00 PM ET, it was discovered the logging system caused a backup in mail processing. The issue has been identified and resolved by the team. However, email flow is still catching up and may continue to be delayed through the end of the business day. We are continuing to monitor mail flow to ensure the mail processing returns to normal as email traffic slows down towards the end of the day.
Posted May 04, 2020 - 17:37 EDT
This incident affected: CloudFilter and SafeSend Email Security.