Phone System Interruption
Incident Report for Mailprotector
Resolved
The phone system operation has been restored. Thank you.
Posted 5 months ago. Aug 16, 2018 - 17:30 EDT
Identified
The phone system is online and accepting calls. Not all extensions answering yet, so please leave a voicemail if you need to get in touch with us. We will return your call as soon as possible. Thank you.
Posted 5 months ago. Aug 16, 2018 - 15:39 EDT
Investigating
We are investigating a phone system interruption. Support calls will be directed to the voicemail system which will create a ticket and we will respond as soon as possible. We are sorry for the inconvenience.
Posted 5 months ago. Aug 16, 2018 - 14:52 EDT
This incident affected: Mailprotector Offices.