SecureStore Maintenance
Incident Report for Mailprotector
Resolved
Access to SecureStore has been restored.
Posted 9 months ago. Oct 25, 2017 - 10:01 EDT
Monitoring
Users will not be able to access the archive for the moment. The login page will be visible, but will not allow a user to log in. We are working as quickly as possible to resume normal operation.
Posted 9 months ago. Oct 24, 2017 - 12:10 EDT