Quarantine release and sign-in links emails not delivering

Incident Report for Mailprotector

Resolved

This incident has been resolved.
Posted Dec 13, 2019 - 15:01 EST

Monitoring

The queues for released messages, sign-in links, and review notifications have been fixed. The team will continue to monitor the situation.

Users may have received all the messages from their previous attempts. Sign-in links will not be valid anymore. Please have them request a new sign-in link.
Posted Dec 13, 2019 - 13:08 EST

Identified

We believe the problem has been identified and the team is working on the fix.
Posted Dec 13, 2019 - 12:52 EST

Investigating

Some users are not able to release emails from the quarantine messages or receive sign-in links. We are investigating the problem.
Posted Dec 13, 2019 - 12:39 EST
This incident affected: CloudFilter and SafeSend Email Security.