Exchange+ 2013 OWA and Client Access
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 12, 2018 - 18:18 EDT
Monitoring
The Client Access Servers operation has been restored. We will continue to monitor the situation. Thank you.
Posted 10 months ago. Sep 12, 2018 - 16:54 EDT
Identified
The problem has been isolated to the Client Access Servers. The team is attempting to restore services as quickly as we can. Thank you.
Posted 10 months ago. Sep 12, 2018 - 16:47 EDT
Investigating
We have received reports of users not able to connect to their Exchange+ 2013 mailboxes. We are investigating the issue.
Posted 10 months ago. Sep 12, 2018 - 16:38 EDT
This incident affected: Exchange+ 2013.