Outbound emails to hotmail.com/live.com/msn.com blocked
Incident Report for Mailprotector
Resolved
At this time, the degraded performance from outbound servers appears to be back to an operational level. Please open a support request at support.mailprotector.com if new bounces to hotmail.com, live.com, msn.com or outlook.com recipients occur.

The removal of IP addresses from service still on Microsoft's SNDS blacklist seems to have eliminated the immediate bounces. The team is continuing to monitor the delisting process and will carefully reinstate IP addresses as appropriate.

Thank you.
Posted 3 months ago. Feb 20, 2019 - 17:21 EST
Update
IP addresses still blocked by Microsoft's free email entities have been removed from service. This action should reduce, possibly eliminate the bounced messages, but could cause a delay in delivery as the volume of outbound messaging is performed by fewer servers.

The team is continuing to monitor the status of IP reputations on Microsoft's SNDS.
Posted 3 months ago. Feb 20, 2019 - 12:30 EST
Update
Unfortunately, Mailprotector's logs show that several IP addresses are still blocked. We are continuing to monitor and work on the delisting process within Microsoft's guidelines.
Posted 3 months ago. Feb 20, 2019 - 10:20 EST
Monitoring
The majority of IP addresses blocked by hotmail.com, live.com, and msn.com have been delisted. We will continue to monitor the progress of remaining IP addresses. Thank you,
Posted 3 months ago. Feb 20, 2019 - 08:52 EST
Update
We are continuing to monitor the reports available from Microsoft and must wait for the delisting process to conclude.
Posted 3 months ago. Feb 19, 2019 - 19:42 EST
Identified
The team has identified an IP reputation problem with the free Microsoft email entities hotmail.com, live.com, and msn.com. We are working with Microsoft to delist the IP addresses as soon as possible.
Posted 3 months ago. Feb 19, 2019 - 17:12 EST
This incident affected: SafeSend Outbound.