Exchange 2013 Certificate Expired Warning
Incident Report for Mailprotector
Resolved
The expired certificate problem has been resolved. Thank you.
Posted 21 days ago. May 03, 2019 - 15:50 EDT
Identified
We have received reports of Outlook reporting a warning that the certificate for exchange.mailprotector.com has expired. The team is working on the issue.
Posted 21 days ago. May 03, 2019 - 15:22 EDT
This incident affected: Exchange+ 2013.