Mailprotector Management Console -- Temporarily Unavailable
Incident Report for Mailprotector
Resolved
At this time, full functionality has been restored to the Mailprotector Console. Once again, please do accept our apologies for any inconvenience. If you have any questions or ongoing concerns, please do reach out to us at support@Mailprotector.com
Posted Dec 09, 2015 - 14:09 EST
Identified
At this time, the Mailprotector Management Console is temporarily unavailable. Full functionality will be restored shortly. Please accept our apologies for any inconvenience.
Posted Dec 09, 2015 - 13:48 EST