Inbound email delivery delayed
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted Mar 09, 2020 - 19:45 EDT
Update
Email delivery performance should be stable. However, log data is still approximately 15 minutes behind. The team will continue to monitor this.
Posted Mar 09, 2020 - 14:52 EDT
Monitoring
A heavy amount of traffic from foreign IP addresses has slowed down the perimeter. The Mailprotector team has identified significant sources and blocked the traffic. Email delivery performance will be returning to normal soon.

Please note, logs in the Console will also be behind as they catch up from the heavy activity.

We will continue to monitor the perimeter systems.
Posted Mar 09, 2020 - 14:02 EDT
Investigating
Mailprotector is investigating email delivery delays. Not all domains appear to be affected. Email is being accepted by the perimeter and remains in the delivery queue. Delays have been between a few minutes to an hour. An update will be posted as soon as we have more information.
Posted Mar 09, 2020 - 13:40 EDT
This incident affected: CloudFilter and SafeSend Email Security.