Access to CloudMail mailboxes interrupted

Incident Report for Mailprotector

Monitoring

A server service was unstable. The team has resolved the issue. Webmail and IMAP access is working as expected. We are continuing to monitor the service.
Posted Oct 01, 2025 - 05:14 EDT

Investigating

We are currently investigating the issue. Email is being accepted in mailboxes; however, access via webmail and IMAP is interrupted.
Posted Oct 01, 2025 - 04:14 EDT
This incident affects: CloudMail Hosted Email.