Inbound mail flow delayed
Incident Report for Mailprotector
Resolved
Inbound mail flow performance is operating as expected. A post-mortem follow-up will be added to this incident in the coming day or two.
Posted Oct 18, 2023 - 15:47 EDT
Update
We are continuing to investigate the issue. Reports have been received of some emails being delayed by 45 minutes.
Posted Oct 18, 2023 - 12:19 EDT
Investigating
We are currently investigating inbound mail flow delays. Observed delays are at 5 to 10 minutes. Some messages may experience longer delays.
Posted Oct 18, 2023 - 11:49 EDT
This incident affected: CloudFilter and SafeSend Email Security.