Shield Mail Flow

Incident Report for Mailprotector

Resolved

Mail flow is functioning at expected performance levels.
Posted Feb 10, 2025 - 13:47 EST

Monitoring

Mail flow response times are reaching 30 seconds or less. We will continue to monitor the situation until the permanent fix is deployed.
Posted Feb 10, 2025 - 12:56 EST

Update

Mail flow response times are continuing to decrease. A fix is planned for deployment to prevent this incident from occurring again. Another update will be provided to confirm improvement or resolution.
Posted Feb 10, 2025 - 12:46 EST

Identified

The issue has been identified and mitigated. The team is working through queued jobs, but mail flow could be delayed by 10 minutes. We are working quickly to return mail flow to expected performance.
Posted Feb 10, 2025 - 11:02 EST

Investigating

We are investigating an impact on mail flow.
Posted Feb 10, 2025 - 10:40 EST
This incident affected: Shield.