Emails to be quarantine unavailable
Incident Report for Mailprotector
Resolved
The AWS outage has been resolved, and CloudFilter's impact has been minimal. Quarantine access and performance are operational.
Posted Oct 07, 2024 - 16:13 EDT
Identified
Emails destined for quarantine by CloudFilter may not be accessed or released due to a problem with Amazon Web Services' S3 storage service. The team is working with AWS to restore expected performance as quickly as possible.
Posted Oct 07, 2024 - 16:00 EDT
This incident affected: CloudFilter and SafeSend Email Security.