CloudFilter mail log data not showing

Incident Report for Mailprotector

Resolved

Email logs for CloudFilter have caught up, and current logs are displaying as expected.
Posted Jul 13, 2026 - 15:44 EDT

Monitoring

Email log data stopped shipping to the storage layer. The team has resolved the log shipping, and the logs are recovering. Log backfill will continue well into the afternoon, and we will update this notice once the logs have caught up.
Posted Jul 13, 2026 - 11:12 EDT

Investigating

Email log data for CloudFilter is not visible in the Console. The issue appears to have started approximately 9:00 AM ET this morning.

The team is investigating the issue, and we will provide more information as soon as we can.
Posted Jul 13, 2026 - 10:33 EDT
This incident affected: CloudFilter and SafeSend Email Security.