Inbound email delivery delay

Incident Report for Mailprotector

Resolved

Inbound delivery has continued to perform as expected. This incident is resolved.
Posted Sep 10, 2025 - 10:21 EDT

Monitoring

Inbound delivery is performing as expected. We are continuing to monitor the flow.
Posted Sep 09, 2025 - 15:18 EDT

Investigating

We are investigating an inbound delivery delay. Delays of approximately 20 minutes have been observed.
Posted Sep 09, 2025 - 14:29 EDT
This incident affected: Shield.