Outbound email delays resurfaced
Incident Report for Mailprotector
Resolved
Log data comparisons indicate the certificate error was the root cause of yesterday's performance. The team is closely monitoring the outbound mail flow. Further investigation into the certificate error and the addition of new monitors for this type of situation are ongoing.

As of this update, outbound mail flow is operating as expected, and Mailprotector expects it to remain healthy going forward.
Posted Mar 21, 2023 - 11:57 EDT
Update
Log data and system observation show outbound mail flow is operating as expected. We are continuing to monitor things closely and will send another update to confirm the resolution later this morning.
Posted Mar 21, 2023 - 09:57 EDT
Monitoring
The outbound surge queue is normal; however, we will continue to monitor the services closely.
Posted Mar 20, 2023 - 21:35 EDT
Update
We are continuing to work on the outbound delivery issue. There is no evidence of a denial of service attack, and we are working on other possible root causes.
Posted Mar 20, 2023 - 20:29 EDT
Update
The team continues to manage the queues and seek the issue's root cause. The behavior is outside the bounds of regular activity, and the team is investigating a potential denial of service attack pattern.
Posted Mar 20, 2023 - 15:53 EDT
Investigating
The team is investigating delays with outbound email delivery. A surge of activity has resurfaced that is being actively managed to push the queues forward.
Posted Mar 20, 2023 - 14:22 EDT
This incident affected: CloudFilter and SafeSend Email Security.