Since April 29, there have been unnoticeable bounces. While we cannot be certain that Microsoft will not repeat the issue, the status is considered resolved at this time. If you receive a bounce for "banned sending IP" or "blocked using Spamhaus", please open a support request.
Posted May 05, 2025 - 09:56 EDT
Monitoring
Since April 30, little to no bounces have been observed. We are continuing to monitor the situation and waiting for Microsoft's response to explain the reason and a permanent resolution.
Posted May 02, 2025 - 09:35 EDT
Update
Bounces over the last 7 days have subsided, but an increase has been observed today, April 29. The number of bounces is tiny; however, we know a single bounce can frustrate a customer.
Communication with Microsoft was escalated last week, and we await more information.
Posted Apr 29, 2025 - 16:21 EDT
Identified
Mailprotector is aware of intermittent bounces of inbound emails to Microsoft 365 domains. The bounces reference one of two reasons: "banned sending IP" or "blocked using Spamhaus."
In both cases, Microsoft and Spamhaus do not indicate that the IP addresses are blocked when a delist request is made. Mailprotector has two open and active support requests with Microsoft to explain and resolve the situation. Mailprotector has been attempting to resolve the issue with Microsoft for over a week. Unfortunately, we have seen increased bounces in the last 24 hours. Partners and users may click on the delist links in the bounce notification. However, the delist will reply that the IP addresses are not listed.
It is important to note that this is not an outbound reputation issue. Microsoft is randomly rejecting emails from IP addresses that only relay inbound emails after being filtered. The IP addresses are added to the recommended inbound connector for M365 deployments.
Posted Apr 17, 2025 - 13:42 EDT
This incident affected: CloudFilter and SafeSend Email Security.