Mass released quarantine emails delayed
Incident Report for Mailprotector
Resolved
The quarantine release queue has cleared.
Posted Oct 17, 2023 - 22:55 EDT
Monitoring
The inbound email flow is operating as expected.

Releasing multiple quarantined emails from the Console is delayed by as much as 40 minutes. A mass quarantine release has been requested and is being processed. To reiterate, normal email flow is not impacted. Only multiple or mass-released emails from the quarantine will experience a delay. The team is monitoring the quarantine release queue.
Posted Oct 17, 2023 - 17:49 EDT
This incident affected: CloudFilter and SafeSend Email Security and Management Console.