CloudMail web UI displaying error when sending email
Incident Report for Mailprotector
Resolved
The error displayed after sending emails from the CloudMail web UI is resolved.

Messages sent from CloudMail were being delayed just enough to the outbound gateway to cause the error in the webmail UI. Mail flow was handled more gracefully on the backend. The team will continue to monitor the handoff between CloudMail and the outbound gateway through May 31.
Posted May 30, 2023 - 17:15 EDT
Investigating
We are investigating an issue with the CloudMail webmail UI displaying "an error occurred during sending the message" despite the email sending successfully. The UI may save the sent email to the Drafts folder.

An optional workaround is to use webmail2.cloudmail.email
Posted May 30, 2023 - 16:06 EDT
This incident affected: CloudMail Hosted Email.