Replies to Support team not being processed

Incident Report for Mailprotector

Update

Support tickets and replies from Mailprotector will temporarily originate from a zendesk.com email address rather than our standard mailprotector.com domain. This is an intentional change we made to restore email reply functionality to our ticketing system.

Emails arriving from zendesk.com on behalf of Mailprotector Support are legitimate. If your email filtering flags these messages as possible impersonation, they are safe to release and trust.

We will update this notice when we return to our standard domain.
Posted Jun 04, 2026 - 10:55 EDT

Identified

We are currently experiencing an issue with our Microsoft 365 tenant that is preventing us from receiving email replies to our support address. We are working to resolve this.

If you need to reach us, please log into the support portal (support.mailprotector.com) and submit or update your request there. Portal submissions are working normally and will reach our team.

We will update this notice once email replies are restored.
Posted Jun 04, 2026 - 09:45 EDT
This incident affects: Service Announcements.