AWS S3 outage causing Shield mail flow problem
Incident Report for Mailprotector
Resolved
AWS has confirmed the issue with S3 storage has been resolved.
Posted Oct 07, 2024 - 16:29 EDT
Monitoring
Per AWS, "Oct 07 1:06 PM PDT Between 12:27 PM and 12:52 PM PDT we experienced increased API error rates for PUT and GET requests to S3 in the US-EAST-2 Region. Other AWS Services that use PUT and GET S3 APIs were also affected. The error rates have recovered, and we continue to investigate root cause."

The service is restored, and Shield mail delivery performance resumes the expected performance. Depending on when the email was sent, some mail delivery delays may occur.
Posted Oct 07, 2024 - 16:15 EDT
Identified
Email delivery to Shield is impacted by an outage of Amazon Web Services' S3 storage service. The team will work with AWS to restore expected services as quickly as possible.
Posted Oct 07, 2024 - 15:56 EDT
This incident affected: Shield.