Inbound email is slow to deliver
Incident Report for Mailprotector
Resolved
This incident has been resolved.
Posted May 06, 2021 - 09:42 EDT
Monitoring
A possible DNS query problem was causing SPF checks to slow down. The team adjusted mail flow to resume healthy levels and will continue to monitor the inbound queues through the end of the business day. Mail flow performance should be back at expected levels.
Posted May 05, 2021 - 17:34 EDT
Investigating
Inbound email servers are experiencing a surge in the queues. The team is investigating the issue. Please expect email delivery to be delayed.
Posted May 05, 2021 - 16:36 EDT
This incident affected: CloudFilter and SafeSend Email Security.