Outbound email delivery delays

Incident Report for Mailprotector

Resolved

The outbound queues are healthy and delivering as expected.
Posted Mar 20, 2023 - 13:08 EDT

Monitoring

Outbound queues are beginning to clear, and we are continuing to monitor the progress.
Posted Mar 20, 2023 - 12:48 EDT

Investigating

We have identified a surge in outbound email delivery. The team is investigating the issue.
Posted Mar 20, 2023 - 12:30 EDT
This incident affected: CloudFilter and SafeSend Email Security.