Deferred emails to Prodigy-protected and Rackspace-hosted domains
Incident Report for Mailprotector
Update
Mailprotector has observed improved deliverability to Rackspace and AT&T domains. However, we are cautious, given that email volume is typically reduced between the Christmas and New Year's Day holidays.

Over the coming weeks, we will move affected servers back into full production and wait for stabilized delivery responses. We expect some deferrals because these email service providers do not offer a means to set an expected volume of emails. We cannot eliminate deferrals entirely, especially if an email is considered questionable for spam or malicious intent.

If the process moves forward smoothly and as expected, we will send one more update in a couple of weeks. We hope to consider this incident complete.
Posted Jan 03, 2025 - 16:57 EST
Identified
Mailprotector resolved a significant reputation issue that affected AT&T and Yahoo domains. As part of that remediation, the volume of emails from affected servers significantly dropped. As the affected servers have been put back into service, some domains using Prodigy (part of AT&T and Yahoo) and Rackspace are deferring email delivery due to the rapid volume change. Mailprotector is mitigating the occurrence of deferrals by metering the volume of affected servers. This process will take several more weeks to reach full resolution.
Posted Dec 11, 2024 - 15:36 EST
This incident affects: CloudFilter and SafeSend Email Security.