Mail log ingestion issue on CloudFilter

Incident Report for Mailprotector

Resolved

The log ingestion issue is resolved, and logs have been backfilled.
Posted Dec 18, 2025 - 18:08 EST

Identified

The team has identified an issue with email log ingestion and backend storage. A fix is being prepared. Logs will get backfilled once the issue is resolved. The log issue does not impact mail flow. Email delivery is performing as expected.
Posted Dec 18, 2025 - 17:06 EST
This incident affected: CloudFilter and SafeSend Email Security and Management Console.