Possible email delivery delays
Incident Report for Mailprotector
Postmortem

The intermittent email delays spotted on June 12, 2020, were caused by a custom regular expression of a message rule. The team identified the rule and confirmed that when it was used to evaluate an incoming email, it would take a very long time and use excessive computing resources.

The offending rule has been modified to prevent runaway resource utilization, and inbound email performance has been operating at normal levels.

Additional logging and notification have been put in place to alert Mailprotector of custom regular expressions that could cause resource problems. Long-term solutions are being explored to continue providing the flexibility of custom regular expressions without the risks of problem rules causing system-wide performance implications.

Posted Jun 15, 2020 - 10:49 EDT

Resolved
The inbound gateways are operating normally at this time. The team will continue to monitor the situation.
Posted Jun 12, 2020 - 21:31 EDT
Update
The team is continuing to investigate the performance abnormality on the inbound gateways. Email delivery is not impacted severely, but delays in some emails are still possible.
Posted Jun 12, 2020 - 16:24 EDT
Investigating
Performance on the inbound gateway has been slow this morning. The team is investigating the issue. Email delivery delays are possible.
Posted Jun 12, 2020 - 12:05 EDT
This incident affected: CloudFilter and SafeSend Email Security.