Mail delivery delays to Microsoft 365 domains

Incident Report for Mailprotector

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 08:50 EST

Update

We will continue to monitor the status Microsoft provides at https://status.cloud.microsoft/. It appears Microsoft is making progress in some of their affected zones. Logs shows some emails are beginning to deliver, but without Microsoft's confirmation of a resolution, we expect deferrals to continue.
Posted Jan 22, 2026 - 18:38 EST

Update

Microsoft's status has not changed. For more information, please visit https://status.cloud.microsoft/
Posted Jan 22, 2026 - 17:36 EST

Monitoring

Microsoft has announced a service issue affecting Exchange Online in M365. We are seeing email delivery delays to M365 domains with temporary error notifications. We will continue to monitor the Microsoft report. Mailprotector's CloudFilter and Shield services are operational.
Posted Jan 22, 2026 - 14:51 EST
This incident affected: Shield and CloudFilter and SafeSend Email Security.