Slow processing of Shield messages

Incident Report for Mailprotector

Resolved

The queues have caught up, and performance is operating at expected levels.
Posted Aug 03, 2026 - 14:31 EDT

Monitoring

At approximately 1:00 PM ET, we were alerted to slow message processing in Shield. The symptoms were slow message updates and some delivery delays. The team has identified the bottleneck and resolved the issue. The queues are catching up, and performance appears to be normalizing. We will continue to monitor the queue for full resolution.
Posted Aug 03, 2026 - 14:14 EDT
This incident affected: Shield.